37 Responses to How to add your Logo in the Login and App window in Open Source or Network Edition

  1. Mohammed Fath Albab September 2, 2015 at 1:48 AM #

    its not working with zimbra open source V 8.0.9 . pls advise.

    • Jorge de la Cruz
      Jorge de la Cruz September 2, 2015 at 3:07 AM #

      Hi Mohammed,
      Did you try the commands in the domain example.com and then you went to mail.example.com, or your FQDN to that domain, and doesn’t work? Are you trying the external logos or the internal path?

      Best regards

  2. Mohammed Fath Albab September 2, 2015 at 3:21 AM #

    I’m using internal path . i tried the command as your mission but after run the command the original logo of zimbra disappeared also . i changed example.com by my domain and changed mail.example.com by my mail server URL. pls advise

    • Jorge de la Cruz
      Jorge de la Cruz September 2, 2015 at 3:36 AM #

      Hi Mohammed, try to apply the proper rights to the Logos, do chown zimbra:zimbra to that files, that can be the issue.

      Best regards

  3. Mohammed Fath Albab September 2, 2015 at 6:04 AM #

    it working fine after change the rights to the Logo but there is another issue , my company logo is not show complete when i try to access thru any browser from computers but its working fine with Mobile version when i tries to access it from my mobile its show complete company logo , this issue in zimbra open source v 8.0.9 .

    i tested the logo also in zimbra open source in v 8.6.0 and it show the logo complete without any problem .
    pls advise if there is any bug with v 8.0.9

    • Jorge de la Cruz
      Jorge de la Cruz September 2, 2015 at 6:38 AM #

      Hi Mohammed,
      Feel free to open a new Thread in our community Forums where I can help you much more if you put there your examples, etc – https://community.zimbra.com/collaboration/f/1886

      You must be sure to comply the CPAL license keeping the Zimbra Logo as well as use the Image size described in this Blog Post, we can discuss it in a Forum Thread.

      I’m glad that now it’s showing the logo after the privileges.

      Best regards

  4. Mohammed Fath Albab September 2, 2015 at 6:55 AM #

    thanks for your support.

    https://community.zimbra.com/collaboration/f/1886/t/1140193

    • Jorge de la Cruz
      Jorge de la Cruz September 2, 2015 at 5:03 PM #

      Hi Mohammed, I think that finally we fixed your issue together aren’t we?

      Best regards

  5. Vavai September 2, 2015 at 3:09 PM #

    Hi Jorge de la cruz,

    Thank you very much. a very clear tutorial with proper step-by-step guide explained with screenshot ;-)

    Like it

    • Jorge de la Cruz
      Jorge de la Cruz September 2, 2015 at 5:03 PM #

      Thank you Vavai, I am a truly big fan of your content as well.

      Best regards

  6. SGWW September 8, 2015 at 7:56 AM #

    Hi

    There is one issue in “Images hosted in external server” method (at least for FOSS edition).
    If we host logo image in external server and use comercial SSL cert, browsers warning us that our https connection has some security issues.

    For example Chrome https status icon changes from Green lock icon to Lock icon with yellow warning triangle, obviously because we use logo image from external website. That really can confuse some users.

    Because of this better to use not recomended method and store logo image locally if you use comercial ssl cert.

    Also could you please advice how to set the default zimbra logo back? Thank you.

    • Jorge de la Cruz
      Jorge de la Cruz September 8, 2015 at 9:24 AM #

      Hi SGWW,
      Hosting the Logo in external place it’s the recommended way because even with upgrades, you will not lose any logo, if you have one domain that maybe sounds not too hard, but if you have 100 domains, with different domains and logos, you will want not to lose all that work with each upgrade. But, because Zimbra is really flexible and each environment is different, both solutions are ok :)

      Chrome will change the color of your Certificate if you embed an image from a HTTP source, like with any other web application, because you are mixing http content and https. I’ve just tried in my side, I have 2 differents SSL, one for zimbra86.zimbra.io and another SSL certificate, completely different for http://www.zimbra.io, and I have green SSL in Chrome, you can try with my images if you want:
      zmprov md zimbra.io zimbraSkinLogoLoginBanner https://zimbra.io/MyLoginBanner.png
      zmprov md zimbra.io zimbraSkinLogoAppBanner https://zimbra.io/MyAppBanner.png

      So I will add a note into the Blog post about that you must have SSL in the Host for the images to avoid SSL issues in the Zimbra Login App.

      Thank you for your comment, really good feedback.

  7. SGWW September 8, 2015 at 11:49 AM #

    Hi Jorge, thank you for your reply. It works with https image source perfectly.

  8. Denny September 13, 2015 at 8:26 PM #

    HI Jorge,.

    The step works I’m following. But if i used the IP for accessing the webmail, the logos not displaying. How to make work if we use Hostname or IP to accessing the web for showing the logos on both.

    Thank you.

    • Jorge de la Cruz
      Jorge de la Cruz September 14, 2015 at 1:43 AM #

      Hi Denny, that is not currently possible, as Zimbra uses the virtual-host to determine which logo must use, so in case of the IP, Zimbra shows the default logo. You always search for the .png image inside the server and replace it there, but is not other easy way to do it.

      Best regards

    • Abobakr osman February 28, 2016 at 1:03 AM #

      you are the Best by showing that logo only shown when using domain not ip , thanks

  9. Sigit October 5, 2015 at 3:48 AM #

    hi Jorge,
    I try to add my company logos in my zimbra web mail using internal path
    but I can’t find folder logos in /opt/zimbra/jetty/webapps/zimbra/, but I found logos folder in /opt/zimbra/jetty/webapps/zimbra/skin/bases/_skin/logos, this same folder,so I put myLogonbanner.png into this folder. after execute command for add my logos, my company logos not showed and zimbra logos in login banner is missing
    how to repair this problem?

    regards

    • Jorge de la Cruz
      Jorge de la Cruz October 5, 2015 at 4:22 AM #

      Hi Sigit,
      Review the Blog article, I’ve updated it clarifying some steps.

      Best regards

    • Sigit October 5, 2015 at 8:08 PM #

      hi Jorge,
      thx for your tips, It works,
      but how to load zimbra logos, because after add company logo, the zimbra logos in login banner is missing

    • Sigit October 5, 2015 at 9:33 PM #

      hi Jorge, sorry, I can solved that

  10. Jingaling November 10, 2015 at 8:27 AM #

    Hi,

    I did this, but I don’t really like the logo. I actually prefer the stock Zimbra image. Is there a way to revert this back to the standard image?

    Thanks.

  11. Jorge Gomes December 14, 2015 at 1:16 PM #

    Hi, it would be nice to also have a way to revert back. In case something goes a bit wrong.

    Season Greetings.

    JG

    • Jorge de la Cruz
      Jorge de la Cruz December 14, 2015 at 1:24 PM #

      Hi, but the original logos, with different colors, like black, white, and color are in this Blog article, you can use them, also, before touch the logos, is always a good practice do a copy first.
      You can find the logos as well here: /opt/zimbra/jetty/webapps/zimbra/skin/bases/_skin/logos

      Best regards

    • Jorge Gomes December 14, 2015 at 1:33 PM #

      Hi Jorge,

      Thanks for the quick reply.

      Yes, I did found those, and using these commands to try to restore them, as I haven’t created the correct ones, such combining the Zimbra logo with ours. Thats why I want to revert it back. But this is not an urgent issue, but due to some threads I found, it would be nice to have a way to revert it.

      My commands:
      zmprov md example.com zimbraSkinLogoURL https://mail.example.com

      zmprov md example.com zimbraSkinLogoLoginBanner /opt/zimbra/jetty/webapps/zimbra/skins/_base/logos/LoginBanner.png

      zmprov md gastao.eu zimbraSkinLogoAppBanner /opt/zimbra/jetty/webapps/zimbra/skins/_base/logos/ZimbraInside/AppBanner.png

      zmmailboxdctl restart

      But, those now can’t appear … going to try the others available.
      Just let me know if the above is correct.

      Thanks.

      JG

  12. Zabidin December 16, 2015 at 9:16 PM #

    This for client. How about for administration? I think need to replace zimbra admin application banner. I’m using network edition 8.0.9. Any idea how?

  13. Nikolas February 9, 2016 at 4:44 AM #

    In the open source edition , can i replace the url that point on my company and zimbra logo image ?

  14. sareesh m February 15, 2016 at 8:39 AM #

    Hi,

    How can i revert back to the initial logo ?

  15. Dipz March 8, 2016 at 9:11 AM #

    Hi Jorge,

    Thank you so much for such a descriptive explanation.

    What I understood as a opensource user we cannot change or lighter the blue colour on login page but can we add something on the grey area to make the website lively?

    As a part of confirmation wanted to know that adding a forgot passoword on login page and adding our companies copyright on login page does not violates any rule.

    Best Regards,
    Dipz

  16. Alisson Ferreira March 8, 2016 at 12:15 PM #

    Is not working in Zimbra 8.6.0. Are there a new procedure for thiese version?

  17. Jesus medina May 19, 2016 at 2:44 AM #

    Hello, I’m new to zimbra, I use the version 8.6.0 and I wonder if you can change the background to the home screen and as I do, I place a background made by me, which files do I change which folder should I place the background created, thanks

  18. odie July 3, 2016 at 11:58 PM #

    Hi Jorge,

    Not working on latest version. Zimbra default logo disapper after modification as well as my company logo.
    Im using Zimbra 8.6.0_GA_1153.RHEL7_64_20141215151110 RHEL7_64 FOSS edition.

    • Jorge de la Cruz
      Jorge de la Cruz July 4, 2016 at 1:12 AM #

      Hi odie,
      Are you using internal image path or external one? Does that folder, and that file have zimbra privileges?

      Best regards

  19. Sergio July 27, 2016 at 7:17 PM #

    Hi everyone! I followed this Howto and all works fine when I access my webmail through internet, but when I access through VPN (internal IP 10.0.30.13) the logo is not showing up.

    What is wrong?

    Best,

    Sergio Bergamini

    • Fabio Soares Schmidt August 1, 2016 at 2:38 PM #

      Hi,

      Is the mailbox service restart really needed? I’ve done the configuration and just running “zmprov fc skin” updated the logos.

      My best regards,
      Fabio S. Schmidt

    • Sergio August 1, 2016 at 8:01 PM #

      Hi Fabio. All services was restarted. I ran “zmprov fc skin” but nothing changed.

      regards,

      Sergio Bergamini

Trackbacks/Pingbacks

  1. Mengubah Logo Login Email pada Zimbra – Fajar Mukharom - June 28, 2016

    […] Sumber: https://blog.zimbra.com/2015/09/change-login-app-logo-open-source-network-edition/ […]

  2. Zimbra: Afinal, posso alterar o logo na versão Open Source? | Respirando Linux - August 1, 2016

    […] https://blog.zimbra.com/2015/09/change-login-app-logo-open-source-network-edition/ […]